さては開発メモだなコレ

開発のメモぶろぐ

rbenvで新しいバージョンのrubyがリストに表示されない

rbenvでruby2.4.1をインストールしようとしたら…

$ rbenv install list
Available versions:
...
2.3.2
2.3.3
2.3.4
2.4.0-dev
2.4.0-devしかない…

rbenvをアップデートしてないのが原因

$ rbenv --version
rbenv 1.0.0



homebrewでインストールしてるので、以下のようにアップデート

$ brew update
$ brew upgrade ruby-build
$ brew upgrade rbenv

rbenvバージョン確認
$ rbenv --version
rbenv 1.1.1



再度インストール可能なrbenvでrubyのバージョンを確認

$ rbenv install list
Available versions:
...
2.3.2
2.3.3
2.3.4
2.4.0-dev
2.4.0-preview1
2.4.0-preview2
2.4.0-preview3
2.4.0-rc1
2.4.0
2.4.1
2.5.0-dev



ruby2.4.1をインストールできるようになりました

$ rbenv install -v 2.4.1